Jump to content
OnyxWizard

Possible Bug?

Recommended Posts

Not sure if this is a bug, but the first upgrade package to unlock and buy for the Americam tier 3 Ship destroyer Clemson doesn't seem to add any sort of stat increase. There is no green text to indicate a stat boost to my guns.

Share this post


Link to post
Share on other sites
11 hours ago, OnyxWizard said:

Not sure if this is a bug, but the first upgrade package to unlock and buy for the Americam tier 3 Ship destroyer Clemson doesn't seem to add any sort of stat increase. There is no green text to indicate a stat boost to my guns.

My mistake @T33kanne can you help out here.

Edited by Ruthless4u

Share this post


Link to post
Share on other sites
1 hour ago, OnyxWizard said:

Sorry Ruthless, I cannot see what you posted. Says I dont have permision.

hi @OnyxWizardi apologize that you cant see this post , it is because this post is at the Alpha Forum , i dont know if it can be reposted at the open Forum because this post  was before NDA lifted ( if we are allowed to repost it )

Share this post


Link to post
Share on other sites

After playing the closed beta, I noticed only a few thing that need to be tweaked and possibly implemented differently. The camo at the start of a match doesn't load in until a few seconds after (usually and 5-10 seconds after the start of the match) and that the servers are overloaded, or the queue is slower than my granny driving to church in the winter. Other than that I'd say the game is launch ready in the state it's in. 

Share this post


Link to post
Share on other sites
10 hours ago, nti9 said:

hi @OnyxWizardi apologize that you cant see this post , it is because this post is at the Alpha Forum , i dont know if it can be reposted at the open Forum because this post  was before NDA lifted ( if we are allowed to repost it )

Thxs for the heads up nti9. I didn't know there was a different forum for the closed beta testers.

Share this post


Link to post
Share on other sites
48 minutes ago, OnyxWizard said:

Thxs for the heads up nti9. I didn't know there was a different forum for the closed beta testers.

It was my fault, did not realize it was from the alpha section until it was pointed out. Tagged T33kanne so hopefully he can give an explanation.

Share this post


Link to post
Share on other sites

For security reasons, please do not provide your personal data or the personal data of a third party here because we might be unable to protect such data in accordance with the Wargaming Privacy Policy.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×